Spout plugin install broken

Hi, I’m trying to get your UE Spout plugin working.

I cannot make the VS project files without adding an empty class. So I deleted the plugin to get the project to start properly again, and tried to make an empty class. Now Unreal will only accept Visual Studio as a compiler option. I use and am accustomed to VS Code, and even after changing UE editor settings to use VS Code for source code, it will only allow me to make an empty class if I install Visual Studio.

This will only be used in Blueprint based projects, and I was hoping for a process that I could show students to get work in and out of Unreal. A lot of Students will be working on machines without Visual Studio available, nor the option to install it. Where possible we try not to force software that will require paid licenses once they’re done studies.

What is the benefit of forcing compile on every install vs just providing the binaries directly in the git repo?
Is there a workaround to forcing everyone to install Visual Studio to compile this plugin?

I just downloaded all 6gb of Visual Studio, restarted, then tried to build Visual Studio project files.

I got an SDK error.

Now I’m trying to launch the project, and it’s returning “Could not be compiled. Try rebuilding from source manually” Almost 2 hrs into trying to get this plugin working, and all I have is a non-functional project.


Which UE version are you using?



This is 4.25.1, the newest.


Hmm, it is possible that some of the files didn’t get pushed to the repo, which is now fixed. So if you clone again, it should work.

For the record, you don’t need VS to build the plugin. In most cases, if it doesn’t build without VS, then installing it most likely won’t change anything (it would allow it to fix it, but that’s not your job :slight_smile: )

To make things easier please find here the plugin already built for 4.25.

Let me know how it goes.


Thanks @meetya - this version seems to work, somewhat.

I’m able to send and receive spout from the demo sender and receiver. But when I try to receive from either Touchdesigner or Resolume, It crashes with:
Fatal error!
Unhandled Exception: EXCEPTION_ACCESS_VIOLATION 0x00000000

This is runing on a Razer Blade 15 with RTX 2020 Max-Q
Drivers are up to date.

I can send and receive between all of those programs, and the demo senders and receivers with no issue. It’s only receiving in Unreal that crashes.

Looks like someone else on the forum was having this issue as well. They weren’t using event tick, though. In this case I was using Event Tick in the level blueprint. (setting a basic cube’s material to the spout material)

Any idea what’s going on here?


It seems this question would be better placed on TD or Resulume forums.

I tested 4.25 with LightAct and it seems to be working.


How exactly would I go about getting help with your Unreal plugin consistently crashing an Unreal project on those forums?

No other combination of sending or receiving spout causes issues, other than receiving into Unreal. I mentioned them as data points for troubleshooting.

To add to the pile of crashiness, the project with your plugin also now immediately crashes if I try to place a basic Niagara system (fountain) into the scene. This only happens in the project with your spout plugin present.

Hello Tim,

Thank you very much for your post.

I understand the plugin is working with Spout Demo Receiver and Sender as well as LightAct and you are having issues using it with a 3rd party software. Do you think it would be worthwhile asking on the Issues page of the original GitHub repository of Spout-UE4 plugin?

As is stated on our repository, we merely modified the original plugin (by AleDel) so that it worked with UE 4.19+ and LightAct. Since then, the changes we implemented, were merged into the original plugin, so as far as we know, they are basically the same.

As a side note, we do strive to help everyone using our fork of the plugin to a certain extent - even if they use it with some of our competitors’ products. It’s one big community after all.

To see this plugin in action with Niagara you might want to have a look at our Unreal Engine sample project. It uses Spout plugin with Niagara.

Good luck with your project, Tim!