Unreallink texture streaming

Hello! After Launch nDisplay I’ve tried to change projector source UE but it’s not working with Texture not present!! please help me


Can you please share your LightAct project.la and ndisplay configuration .cfg file?


Best regards,

of course!!! test.la (29.2 KB)


I looked at your .la file, however it seems it has 4 video screens and no projectors.

Are you sure you sent me the correct file? Also, may I ask where did you get the screenshots of Princess Zelda? What did you use to create this project from?

Thank you,

No that’s not my file. I’ve never seen that before.


I’m going to have to look into that tomorrow when im back in the office. A general note though: you don’t need to insert UE Texture Reader node in the Devices window nor o you need UE Texture Listener node in the layout.

With projection mapping workflow using nDisplay, the textures are shared directly from nDisplay file, so you don’t even need to modify your blueprints at all, which I am assuming you did since you are using vp_1 as the handle name in UE Texture Reader node. Also, the projector in LightAct should be able to receive the texture directly - bypassing any UE Texture Reader node etc.

I’ll try to run your cfg file tomorrow and let you know what I find.


Thank you for your help.I hope tomorrow comes fast!!

Hello @111,

I ran some tests and it appears that there is something in your yes Unreal project causing Texture Sharing through nDisplay to fail. For example, I used the same plese.cfg config file on another packaged project and the texture appeared.

If you can, please feel free to send over your Unreal Engine project so we can have a look at it.

Alternatively, please create a brand new Unreal Engine 4.26 project. The easiest way is to use the nDisplay template, which comes with some settings predefined. However, if you want to use a blank template or if you want to modify your existing project, you need to follow the steps outlined in this article on Unreal’s support pages.

The general steps are as follows:

  1. you save the map/level and set it as the Editor and Game startup map in Project settings. Don’t add any texture sharing nodes in any blueprints, because the are not needed.
  2. Enable nDisplay plugin. You will probably need to restart the Editor.
  3. Go to project settings, Plugins section and find nDisplay page. In there make sure you check the Enabled checkbox.
  4. In the Project/Description page, make sure that Use Borderless Window is checked.
  5. package the project for Windows and make sure that it works correctly by double clicking the exe file.
  6. then use this packaged project to test the texture share with your LightAct project and the corresponding .cfg configuration file.

Let me know how it goes,

As your advice, I made a new project and experimented with it, but I failed. If possible, could you send me your empty project?



Please find here Unreal project that is based on nDisplay template. I’ve tested and it works on my end. Please let me know if it does on yours too.

I’ve also tried with your project and you are right, it doesn’t seem to work correctly although we will need to investigate a bit deeper to find out the reason.

In any case, please let me know how it goes and if you are facing any other difficulties.


This template has been tried before but failed. But I can’t trust my lightact setting. so, If possible, would you send me an (la)file with appropriate setting??


Please find below the entire package including the fixed plese file and packaged nDisplayTemplate project in the assets/unreal folder.


Please make sure that your projector is mapped to the correct machine…


It works perfectly even if you change the packaged file based on nDisplayTemplate project !!!. Based on the file and template you sent me, I can make a new project. Thank you for your help!!!

1 Like

Hi @111,

I’m glad it works on your end. I’ve investigated a bit deeper and found out the reason why it didn’t work with a blank template. You need to follow the steps outlined in this page and then any Unreal project will work properly with texture share.

I’ve also edited my response above to reflect this.

Thank you again for your patience :slight_smile:

1 Like