Mix two textures

Good morning.
I need to mix two textures and be able to lower the intensity of the textures separately so that the output gives me either 100% of texture 1 or 100% of texture 2 or a combination of both textures.
I’ve tried with the texture mix and texture channel multiply nodes but I don’t get a mix.
Thank you so much.

All the best

Eduardo Cueto

Hi,

I normally would expect to do this with the “Texture Blend”-Node. I think this what you mean by “Texture Mix”.
One solution is to map two canvases to e.g. one Videoscreen. Now you can control the canvas opacity and mix the textures this way.

Cheers
Jan

1 Like

Hi @Cueto ,

As @janosc kindly suggested, alternatively you can use the Texture Blend node in Normal mode. In this mode, if the Blend strength is set to 0, then Texture 1 will be at full opacity.

Contrarily, if the Blend strength is set to 1 then Texture 2 will be at full opacity.

All Blend strength values in between will ensure a combination of both Textures.

Hope this helps!

Cheers,
Sara

Hi Sara,

thanks! Too many knobs and forms to look at… :wink:
I definitely need to come to Slovenia for a longer Lightact-Workshop.

Cheers
Jan

Thank you very much for your reply.
I’ve been trying etxture Blend for my mix of textures but there is a drawback and that is that the resulting texture takes the resolution of the first texture.
Can this problem be solved?
thank you so much

Which resolution would you like it to have?

If the mixture deforms the texture, this system does not work for me to mix two videos, images, etc.


Hi @Cueto ,

If I understand correctly, you would like both of the Textures to keep their original resolutions, with no stretching applied.

I created a layer template which might be of help. All you have to do is insert the layer template on your sequence, assign the same Canvas to both Render to Canvas nodes and choose the desired blending mode in the Canvas Properties.

When you adjust the Layer variable called Blend Strength, you should be able to see the Textures blend on the Canvas.

CustomBlend

Hope you found this useful!

p.s. due to some restrictions, it is not possible to attach a layer template in a post, which is why I have sent it to you via email. If anyone else would like access to the layer template, please let us know and we will email it to you.

Cheers,
Sara

Hello good morning.
I have tried the new version of the texture blend node and it continues to take the resolution of the first texture if the second one is a little larger in height, for example, I would crop it in the blend.
If we want to use the texture blend node to mix two textures, it should adapt to the resolutions of the textures that it has to mix.
I also think there should be a value for:
texture 1 ->100% / texture 2 ->0%
texture 1+2 ->100%
texture 2 ->100% / texture 1 ->0%.
Well it’s a proposal.

Eduardo Cueto

Hi @Cueto ,

I understand what you mean. So in the screenshot you have attached, if Stretch checkbox is disabled, you would expect the resolution of 2808x541px.

Can you explain the additional values a little more?

If I understand your goal correctly, then you can already achieve all of this with adjusting the Blur strength. For example, if you have chosen Normal Blend Mode:

  • Blur strength = 1.000 refers to scenario: texture 1 ->100% / texture 2 ->0%
  • Blur strength = 0.500 refers to scenario: texture 1+2 ->100%
  • Blur strength = 0.000 refers to scenario: texture 2 ->100% / texture 1 ->0%

Is this what you were referring to?

TextureBlendStrength

Best,
Sara

Sorry, maybe I didn’t explain it well.
If the second texture is larger than the first,“texture blend” cuts it.

If the first texture is larger, the image is seen below.

So I think what blend texture does is put the texture above or below it, there is no fader at 0.

so this is not true.

Blur strength = 1,000 refers to the scenario: texture 1 ->100% / texture 2 ->0%
Blur strength = 0.500 refers to the scenario: texture 1+2 ->100%
Blur strength = 0.000 refers to the scenario: texture 2 ->100% / texture 1 ->0%.

all the best

Eduardo Cueto

Hi @Cueto,

Apologies for the late reply.

I understand your point regarding the second texture being cropped out, thank you for bringing it to our attention. However, I did not quite understand what you mean by ‘there is no fader at 0’. Could you please elaborate?

Perhaps it would be helpful if you could demonstrate how the texture blending looks in LightAct already and then compare it to what you would expect it to look like. Does this make sense?

Best,
Sara

As I told you, what texture blend does is put one texture on top of the other… but it does not set the intensity to 0.


For these examples that I give, I have forced texture blend to take the resolution of the screen where the texture is rendered.
Obviously I could also create a mechanism that mixes one texture with the other and at the same time lowers the opacity but this could be done by texture Blend… apart from what I mentioned about trimming the texture.
All the best
Eduardo Cueto

Hi @Cueto,

Thank you for the further explanation. We now perfectly understand what you mean and will discuss your suggestion and the feasibility of its implementation with the LightAct team.

Best,
Sara