Projectfile can not be compiled by Visual Studio

Following the video ’ 2. Intro to UE4 & LightAct Integration’ I can not open the UE4 projectfile in Unreal 24.3 ‘Generate Visual Studio files’ works but when I left click on the project and confirm that I want to built the plugins I get the error message: nameofproject could not be compiled. try rebuilding from source manually. Maybe my visual studio installation is not configured right? Which version with which packages should i use?
I followed this link in order to install visual studio:

Unreal Engine Sample Project on our website has been created with 4.24 so it should compile and open successfuly with this version.

Can you please confirm you downloaded this sample project recently and you are still getting this problem?

Otherwise, we use Visual Studio 2017 in the office, but we should work with 2015 as well.

I downloaded the sample project file. It doesn’t show the same error; building works but the initialization of the editor gets stuck at 39% in 4.24.3. I can’t use 4.23 in this project.


I believe that the editor is not actually ‘stuck’ but it just needs to do what it needs to do. That’s my experience at least. I think that 39% and sometimes, I believe, 89% are points which, depending on what the Editor needs to rebuild (plugins, shaders etc.), can take quite some time.

My suggestion would be to just let it do its thing for some time.

Also: I noticed I made a mistake above: the sample project was created using 4.24 not 4.23. Sorry for the confusion.

Let me know how it goes,

Dear Mitja, indeed the project opens after ~10 min - I can confirm that. I would like to test if OSC works with engine nr 4.24. How can i do that?


That’s good to hear. I know I’ve cursed quite a few times waiting for UE Editor to open too … :slight_smile:

As for the OSC, perhaps the best way to start would be this tutorial:

or maybe even this one:

Then there is also this user manual.

Let me know how it goes,

Thank you for the Tutorials, but is there a way to build the plugins in UE 4.24 with out using that project file you suggested? I mean in the way it was described here: Unreal Engine 4 and Lightact Part 1: Installing UE plugins | Lightact or isn’t that currently possible?


Yes, we’ve updated LightAct plugin on GitHub 2 days ago. This plugin seems to have been the cause of the problems and we’ve tested Spout plugin with 4.24 again.

Could you please download LightAct plugin from our GitHub again and let me know how it goes?

Best regards,

Hi, just download the plugins again for github and but it still doesn’t work for me; when I get asked if i want to build the .dlls and yes i get the same error message from the first post in 4.24.3. I saw 4.25.0 came out today maybe you want to update the plugins directly to that version?

Best, Chris


Could you please let me know which plugin is causing the problem. Is it Spout-UE4 or LightAct-UE4. You might need to try with just one of them to find that out.

Then we can proceed in trying to help you.


p.s. we will test 4.25 compatibility in the next few days.

Hi Mitja, I already tested the LigthAct Plugin alone and it doesn’t work (because interested in that one at the moment). Now after your response I tested the Spout as well (alone) and this does work. So so the problem for me is in the LightAct Plugin.
Best, C

Hi Chris,

Thanks for letting me know.

I believe I found the issue and uploaded the fix. Could you please download the plugin again and give it a go?

Also, I downloaded 4.25 and it seems that both LightAct and Spout plugins work.

Please let me know how it goes on your end.


Hi Mitja, it’s still not working for me. I don’t know if there is something wired going on on my pc but the spout plugin builds but the lightact does not…

Hmm…that’s weird. I don’t have any ideas at the moment. You do first click on Generate project files and then try to open the project right?

If you open the .sln file in Visual Studio 2017 and open the LightactBPLibrary.cpp and LightactBPLibrary.h, do you see any Intellisense errors?

It should look similar to this:


If I open that in Visual Studio 2017 I get the error for both files: that a part of that file is missing

Not really familiar with Visual Studio, could it the that the install has a problem (VS 2017) but its strange that the spout plugin seems to work…

this seems really strange (a lot of those in this conversation :)…

What I would try in your place is this:

  1. clean solution in VS2017 and try to build it again

  2. create a new blank UE4 project from Epic Launcher, add code to it (by adding a new C++ empty class) and copy LightAct plugin to Plugins folder and see if it works.

My bet is on point 2… :slight_smile:

Let me know,


It finally worked by adding a empty c++ class! But i can’t still test osc communication because following the video’ Unreal Engine 4 & OSC with Lightact Media Server | Lightact’ I can’t get osc or udp messages into lightact. I’ve set everything as described but now messages arrive…